Sie sind nicht angemeldet.

QuoVadis (aka Tom) hat es geschafft! Neu, kompatibel mit QuoVadis7 für Microsoft Windows:
Three for the road, unser mobiles Trio, QuoVadis Mobile für iOS, Android und Windows Phone
Unsere Apps für die Smartphone Betriebssysteme, vollwertige standalone Navi und Tracker,
im Datenaustausch kompatibel zu QuoVadis 7.1. Karten können aus QV7.1 für QVM exportiert werden!
  • »Stups« ist der Autor dieses Themas

Beiträge: 7

Registrierungsdatum: 14. März 2013

1

Montag, 12. Februar 2018, 21:57

"Aktiven Kartenbereich auf Kalibrierung setzen" funktioniert nicht

Hallo zusammen,

ich habe gerade eine selbst eingescannte Karte importiert und kalibriert und möchte jetzt den aktiven Kartenbereich unter QuoVadis 7.3.0.38 festlegen.

Nach öffnen der Karte und des Projektmanagers habe ich in der Kartendatenbank die Karte ausgewählt und "Aktiven Kartenbereich auf Kalibrierung setzen" ausgewählt und mit "OK" bestätigt.

Trotz der Auswahl im Projektmanager "Aktiver Kartenbereich" wird dieser nicht angezeigt. Für früher gescannte Karten gibt es kein Problem.

Kann mir jemand weiterhelfen ... DAU ... oder doch ein Bug?

Danke für die Hilfe,
Stups.

Sir-Vival

Admin hc Type "M"

Beiträge: 2 597

Registrierungsdatum: 14. April 2004

Wohnort: Neuss

2

Donnerstag, 15. Februar 2018, 09:21

Hallo Stubs,
nur damit ich das richtig verstanden habe: Du hast bei der betreffenden Karte im Projektmanager unter "internal" den AKB auf sichtbar gesetzt und er liegt nicht auf den Kalibrierpunkten?
Was passiert denn, wenn Du den AKB mit dem Editieren - Werkzeug an die richtige Stelle schiebst? Bleibt dieser dann erhalten?

Alternativ könntest Du versuchen, die Datenbank, in der die Karte liegt, einmal zu komprimieren, um eventuelle Fehler dort auszuschließen.

Bringt das Erfolg?

Viele Grüße
Denis

  • »Stups« ist der Autor dieses Themas

Beiträge: 7

Registrierungsdatum: 14. März 2013

3

Donnerstag, 15. Februar 2018, 18:46

Hallo Denis,

bei mir ist überhaupt kein Aktiver Kartenbereich sichtbar, daher kann ich auch nicht verschieben. Datenbank komprimieren bringt auch keine Besserung.


Das Problem ist bei mir unter QuoVadis 7.3.0.38 in folgendem Szenario reproduzierbar:

- Neue Datenbank erstellen
- Neue Kartentabelle erstellen
- Neue Karte Importieren
o Eine einzelne Karte oder mehrere Karten aus einem Verzeichnis importieren
o 45 MB große TIF Datei auswählen
o in Kartentabelle speichern
- Karte öffnen
- Karte kalibrieren
o Name, Maßstab, Kartennummer eingeben
o Nicht von einer anderen Karte importieren
o WGS84, UTM Zone 32 angeben
o 2x2 Punkte auswählen (z.B. 32 N 673.000 5.185.000, 32 N 693.000 5.160.000)
o P1 - P4 auf Karte auswählen
- Projektmanager öffnen
o Internal --> Aktiver Kartenbereich auswählen
- Aktiven Kartenbereich auf Kalibrierung setzen
o OK

Es ist jetzt überhaupt kein Aktiver Kartenbereich sichtbar.

Ich sehe auch keine andere Möglichkeit einen AKB zu erzeugen.

Viele Grüße,
Stups.

Horst_H

Admin hc

Beiträge: 7 246

Registrierungsdatum: 4. November 2004

Wohnort: Stutensee

4

Donnerstag, 15. Februar 2018, 21:37

Hallo,

bei mir ist überhaupt kein Aktiver Kartenbereich sichtbar,
den Button zum anzeigen der AKBs hast Du aber schon betätigt?
siehe Wiki

Gruß
Horst

  • »Stups« ist der Autor dieses Themas

Beiträge: 7

Registrierungsdatum: 14. März 2013

5

Freitag, 16. Februar 2018, 07:52

Hallo Horst,

danke für den Hinweis, aber auch die Ansicht über den Kartenübersicht-Icon zeigt bei mir den AKB für diese Karte nicht an. Für andere Karten in der Umgebung sind sie dann sichtbar.

Mittels "Internal --> Aktiver Kartenbereich auswählen" (wie unten beschrieben) sollte der AKB für diese Karte auch sichtbar sein.

Gruß,
Stups.

Sir-Vival

Admin hc Type "M"

Beiträge: 2 597

Registrierungsdatum: 14. April 2004

Wohnort: Neuss

6

Freitag, 16. Februar 2018, 12:07

Hallo Stups,
kannst Du uns/mir irgendwie die Karte zukommen lassen? Dann würde ich es einfach mal selber ausprobieren. Schön wäre, wenn Du auch die Kalibrierung mit dazu packst, dann ist es sicher so wie bei Dir. Du kannst mir z.B. eine Mail schicken und die Karte auf irgendeinen Hoster hochladen.

Viele Grüße
Denis

Sir-Vival

Admin hc Type "M"

Beiträge: 2 597

Registrierungsdatum: 14. April 2004

Wohnort: Neuss

7

Freitag, 16. Februar 2018, 20:23

Hallo Stups,
danke für das Zusenden. Ich musste ein wenig rumprobieren, glaube aber tatsächlich, dass hier auch ein Bug vorhanden ist und Tom da mal ran muss. Dazu am Ende des Threads mehr.
Zunächst mal zu Deiner Karte: Deine Karte ist leider falsch kalibriert. Nur ein Punkt, namlich P4, stimmt mit dem aufgedruckten UTM Gitter überein, aller anderen Punkte liegen deutlich neben den anderen Gitterschnittpunkten. Somit kommt es zu einem erheblichen Versatz und auch einem Springen des Cursors. Auch scheint die Karte durch das Scannen ein Stück weit verzerrt zu sein, wenn auch nur ein paar Millimeter. Ich schicke Dir meine Kalibrierung mal per Mail, dann kannst Du es vergleichen.
Nur als Tipps für die Zukunft: Um eine Kalibrierung zu überprüfen kannst Du z.B.
1.) das Gitternetz einschalten. Wenn Du zuvor unter "Einheiten..." die passende Einheit ausgewhät hast, muss es bei richtiger Kalibrierung deckungsgleich mit dem aufgedruckten Kartengitter sein.
2.) eine Overlaykarte im Vektorformat laden und schauen, ob die Wege und Straßen übereinstimmen. Dies geht z.B. sehr gut mit den OSM Paketen, die man unter dem Verzeichnis "Download Pakete" im Xplorer herunterladen kann.
3.) gucken, ob der gesetzte Cursor springt, d.h. die gesetzte Markierung von Deinem tatsächlichen Klick abweicht. Passiert das, ist das eigentlich ein sicheres Zeichen für einen Fehler. Bei Deiner Kalibrierung gab es beispielsweise einen Versatz von fast 2cm.

Mir ist auch noch nicht ganz klar, warum Du den AKB auf die Kalibrierung setzen wolltest? Deine Kalibrierungspunkte liegen deutlich im Kartenbild. Das bedeutet, dass Du z.B. Deine Karte nicht angeboten bekommst, wenn Du auf einen Punkt zwischen einem Kalibrierungspunkt und dem Rand Deiner Karte klickst. Hier ist es am besten, wenn Du den AKB - wenn er so genau sein soll - mit dem Editieren Werkzeug manuell verschiebst.

----

Jetzt zum Bug: QV 7.3.0.41
Ich hab es jetzt nur mit einer Tiff Karte probiert (8 Bit, LZW): Karte mit UTM, WGS84 kalibriert. AKB ist nach dem frischen Kalibrieren vorhanden und umschließt die gesamte Karte (sichtbar über internal). Geht man nun über den Xplorer und wählt die Option "Karte kalibrieren, Aktiven Kartenbereich auf Kalibrierung setzen..." verschwindet der AKB und kann nicht mehr zur Anzeige gebracht werden, egal ob Karte schließen, neu starten o.ä.
Auch die Option "Aktiven Kartenbereich entfernen..." bringt keine Änderung oder Besserung. Für mein Verständnis müsste der AKB danach ja wieder die gesamte Karte umschließen.
Tom, kannst Du da bitte mal nach schauen?

Viele Grüße
Denis

  • »Stups« ist der Autor dieses Themas

Beiträge: 7

Registrierungsdatum: 14. März 2013

8

Samstag, 17. Februar 2018, 05:57

Hallo Denis,

danke für die Hinweise. Stimmt, die Kalibrierung in meiner Testdatenbank, das ich beim schreiben des Szenarios oben verwendet habe, ist von mir etwas lieblos gemacht worden. In meiner Kartendatebank stimmt sie.

Die Verzerrung der Karte kommt durch das stitchen der DIN A4 einzelscanns mit Hugin, trotz Anleitung für das Zusammenfügen von Scanns habe ich es nicht besser hinbekommen :-( Mit eingeschaltetem Gitternetz (guter Tip) kann ich jetzt sehen, dass es zu Ungenauigkeiten in Ost-West Richtung von bis zu 40m gibt, für meine Anwendung passt das aber erst mal.

Ich wollte einen AKB setzen, da bei mir nach dem Kalibrieren keiner vorhanden ist. Auch nach erneutem Kalibrieren in meiner Testdatenbank ist kein AKB zu sehen. Diesen erzeugten AKB wollte ich dann mit dem Editieren Werkzeug an die Karteninhalte anpassen. Für alte Karten habe ich da kein Problem die AKBs zu sehen und auch anzupassen.

Workaround für mein Problem ist einen Eintrag einer alten Karte (mit AKB) in einer Kartentabelle zu duplizieren und alle Werte incl. Kalibrierung für die neue Karte anzupassen. Man kann den AKB dann mit dem Editieren Werkzeug auf die wirklichen Karteninhalte verschieben.

Viele Grüße,
Stefan.