Sie sind nicht angemeldet.

QuoVadis (aka Tom) hat es geschafft! Neu, kompatibel mit QuoVadis7 für Microsoft Windows:
Three for the road, unser mobiles Trio, QuoVadis Mobile für iOS, Android und Windows Phone
Unsere Apps für die Smartphone Betriebssysteme, vollwertige standalone Navi und Tracker,
im Datenaustausch kompatibel zu QuoVadis 7.1. Karten können aus QV7.1 für QVM exportiert werden!

Lieber Besucher, herzlich willkommen bei: QuoVadis Supportforum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »schnoeppi« ist der Autor dieses Themas

Beiträge: 83

Registrierungsdatum: 19. Januar 2005

Wohnort: NRW - Niederrhein

1

Mittwoch, 19. Januar 2005, 09:30

Pathaway & GPSGate - Checksum Fehler

@All,

Ich habe folgendes Problem mit der aktuellen Version:
Um die Funktionen von Pathaway zu Testen benutze ich GPS-Gate in der aktuellen Version und eine NMEA-Logdatei die auf einem virtuellen Port als Simulation eines GPS-Empfängers ausgegeben wird. :!:

Diese Konfiguration klappt mit dem OZI-Explorer. Das Programm erkennt die NMEA-Sätze und kann den Track aufzeichnen. :crazy:

PathAway erkennt auch die Schnittstelle, kann die Daten auch einlesen, erkennt ebenfalls einen 3D-Fix. Ich bekomme jedoch immer einen "Invalid Checksum". PathAway erkennt keinen Fix und keinen View. Somit kommt auch kein Track auf meine Karte. :-|
Ab und an bekomme ich auch dazu noch den Fehler "FlushComm Buffers"... :cry:

Als Protokoll habe ich NMEA ausgewählt, der Virtuelle Port stimmt auch, die Baudrate steht auf 9600.
Ich habe auch bereits alle NMEA-Protokolle ausgewählt.

Was kann ich noch tun, damit diese Konfiguration auch unter PathAway läuft?

Danke.
Schnoeppi

jockel

Administrator

Beiträge: 17 538

Registrierungsdatum: 29. Januar 2002

Beruf: Admin

2

Mittwoch, 19. Januar 2005, 11:42

Hallo,

stell die Baudrate mal auf 4800, die "gehört" per Definition zu NMEA,
vielleicht hilft das.
Gruß
Jockel (QV-Admin)

Angefragte Daten für Supportfälle bitte schicken an info/at/quovadis-gps.com unter Bezugnahme (link) auf diesen thread, Danke!

  • »schnoeppi« ist der Autor dieses Themas

Beiträge: 83

Registrierungsdatum: 19. Januar 2005

Wohnort: NRW - Niederrhein

3

Mittwoch, 19. Januar 2005, 11:56

@jockel,

herzlichen Dank für die Hilfe.
Die Baudrate 4800 habe ich probiert, ist jedoch nicht das Problem.

PathAway scheint sich am Format der GPS-Daten zu stören und verlangt zwingend eine CheckSum, sonst käm ja nicht dieser Fehler.

Kann man diese CHKSUM-Prüfung irgendwo ausschalten?

Grüsse
Schnoeppi

jockel

Administrator

Beiträge: 17 538

Registrierungsdatum: 29. Januar 2002

Beruf: Admin

4

Mittwoch, 19. Januar 2005, 14:29

Hallo,

Zitat von »"schnoeppi"«

....PathAway scheint sich am Format der GPS-Daten zu stören und verlangt zwingend eine CheckSum, sonst käm ja nicht dieser Fehler. Kann man diese CHKSUM-Prüfung irgendwo ausschalten?

nein, nicht daß ich wüßte.
Ist ja auch nicht der Punkt, die Überprüft die Daten auf korrekte Übertragung.
Wenn da Müll kommt ist sie halt falsch und es gibt eine Fehlermeldung,
mach ja anders auch keinen Sinn. Was ich nicht weiß, ist, ob die von Dir
verwendeten Programme möglicherweise die "Checksum" des Garmin NMEA
Satzes überhaupt ausgeben?
Wenn das erstellende Programm die Sätze ohne Checksum ausgibt und Ozi
die beim Einlesen ignoriert, wäre das möglicherweise eine Erklärung.

Kannst Du das mal loggen was da Original von GPS-Gate gesendet wird?
Gruß
Jockel (QV-Admin)

Angefragte Daten für Supportfälle bitte schicken an info/at/quovadis-gps.com unter Bezugnahme (link) auf diesen thread, Danke!

Beiträge: 285

Registrierungsdatum: 16. Juni 2004

Wohnort: Unterhaching

5

Mittwoch, 19. Januar 2005, 14:38

Hallo zusammen,

vielleicht hilft es Euch ja bei der Fehlersuche: ich verwende auch GPSGate zusammen mit Pathaway und es funktioniert problemlos.

Hier meine Einstellungen:
1. GPSGate
Input: "COM Port" ==> "COM2" ==> "4800"
Output: "Virtual Ports" ==> "COM6"

2. Pathaway
Protokoll: "NMEA" (nicht Garmin NMEA)
Port: "COM6:"
Baud: "4800"

Der Rest ist die unveränderte Standardeinstellung, also im Register "Ereitert":
Parity: "N"
Bits: "8"
Stop: "1"

Hoffe es hilft.

Gruß,
Birdman

  • »schnoeppi« ist der Autor dieses Themas

Beiträge: 83

Registrierungsdatum: 19. Januar 2005

Wohnort: NRW - Niederrhein

6

Mittwoch, 19. Januar 2005, 14:43

@jockel,

Ich verwende einen Royaltek RBT-3000 Bluetooth-Empfänger...
Ich weiss aber nicht ob die ChkSum-Sätze erzeugt werden..
Hier mal ein paar Sätze aus der NMEA-Datei:

$GPGGA,210524.000,5136.2398,N,00641.3177,E,1,10,8.4,0.0,M,100,M,1.7,0000*56
$GPRMC,210524.000,A,5136.2398,N,00641.3177,E,000.0,000.0,091204,,*0D
$GPVTG,000.0,T,,,000.0,N,000.0,K*2D
$GPGSA,A,3,08,24,10,27,28,17,26,29,,,,,2.3,1.4,1.9*37
$GPGSV,3,1,10,08,80,088,42,10,67,252,42,27,47,062,41,29,43,290,39*75
$GPGSV,3,2,10,28,31,153,43,17,27,276,38,26,22,286,31,21,10,328,*7B
$GPGSV,3,3,10,13,09,100,,24,08,219,33*76
$GPGGA,210524.000,5136.2288,N,00641.3083,E,1,10,8.4,-2.0,M,100,M,1.7,0000*73
$GPRMC,210524.000,A,5136.2288,N,00641.3083,E,000.0,000.0,091204,,*07
$GPVTG,000.0,T,,,000.0,N,000.0,K*2D
$GPGSA,A,3,08,24,10,27,28,17,26,29,,,,,2.3,1.4,1.9*37
$GPGSV,3,1,10,08,80,088,42,10,67,252,42,27,47,062,41,29,43,290,39*75
$GPGSV,3,2,10,28,31,153,43,17,27,276,38,26,22,286,31,21,10,328,*7B
$GPGSV,3,3,10,13,09,100,,24,08,219,33*76
$GPGGA,210524.000,5136.2421,N,00641.3198,E,1,10,8.4,0.0,M,100,M,1.7,0000*52
$GPRMC,210524.000,A,5136.2421,N,00641.3198,E,000.0,000.0,091204,,*09
$GPVTG,000.0,T,,,000.0,N,000.0,K*2D
$GPGSA,A,3,08,24,10,27,28,17,26,29,,,,,2.3,1.4,1.9*37
$GPGSV,3,1,10,08,80,088,42,10,67,252,42,27,47,062,41,29,43,290,39*75
$GPGSV,3,2,10,28,31,153,43,17,27,276,38,26,22,286,31,21,10,328,*7B
$GPGSV,3,3,10,13,09,100,,24,08,219,33*76
$GPGGA,210524.000,5136.2290,N,00641.3099,E,1,10,8.4,0.0,M,100,M,1.7,0000*5E
$GPRMC,210524.000,A,5136.2290,N,00641.3099,E,000.0,000.0,091204,,*05
$GPVTG,000.0,T,,,000.0,N,000.0,K*2D
$GPGSA,A,3,08,24,10,27,28,17,26,29,,,,,2.3,1.4,1.9*37
$GPGSV,3,1,10,08,80,088,42,10,67,252,42,27,47,062,41,29,43,290,39*75
$GPGSV,3,2,10,28,31,153,43,17,27,276,38,26,22,286,31,21,10,328,*7B
$GPGSV,3,3,10,13,09,100,,24,08,219,33*76
$GPGGA,210524.000,5136.2379,N,00641.3102,E,1,10,8.4,-6.0,M,100,M,1.7,0000*70
$GPRMC,210524.000,A,5136.2379,N,00641.3102,E,000.0,000.0,091204,,*00
$GPVTG,000.0,T,,,000.0,N,000.0,K*2D
$GPGSA,A,3,08,24,10,27,28,17,26,29,,,,,2.3,1.4,1.9*37
$GPGSV,3,1,10,08,80,088,42,10,67,252,42,27,47,062,41,29,43,290,39*75
$GPGSV,3,2,10,28,31,153,43,17,27,276,38,26,22,286,31,21,10,328,*7B
$GPGSV,3,3,10,13,09,100,,24,08,219,33*76
$GPGGA,210524.000,5136.2309,N,00641.3085,E,1,10,8.4,0.0,M,100,M,1.7,0000*52
$GPRMC,210524.000,A,5136.2309,N,00641.3085,E,000.0,000.0,091204,,*09
$GPVTG,000.0,T,,,000.0,N,000.0,K*2D
$GPGSA,A,3,08,24,10,27,28,17,26,29,,,,,2.3,1.4,1.9*37
$GPGSV,3,1,10,08,80,088,42,10,67,252,42,27,47,062,41,29,43,290,39*75
$GPGSV,3,2,10,28,31,153,43,17,27,276,38,26,22,286,31,21,10,328,*7B
$GPGSV,3,3,10,13,09,100,,24,08,219,33*76
$GPGGA,210524.000,5136.2363,N,00641.3109,E,1,10,8.4,1.0,M,100,M,1.7,0000*5A
....

@birdman,
danke schön für die Einstellungen. Diese sind bei mir aber richtig gesetzt, denn Pathaway empfängt definitiv Sätze. Ich kann die Sätze ja auch loggen. Es tritt aber immer wieder der ChkSum-Fehler auf!
Trotzdem Danke.

jockel

Administrator

Beiträge: 17 538

Registrierungsdatum: 29. Januar 2002

Beruf: Admin

7

Mittwoch, 19. Januar 2005, 15:35

Re: Pathaway & GPSGate - Checksum Fehler

Hallo,

Zitat von »"schnoeppi"«

Ich habe folgendes Problem mit der aktuellen Version:

eine "aktuelle Version" war gestern eine andere als heute und ist morgen
wieder eine andere, dann steht der Beitrag aber immer noch im Forum ;-)
Ergo, welche Version PW läuft bei Dir ?
Welche Hardware?
Mach mal einen Soft Reset, stell PW mal auf "Holux-NMEA" und versuche es nochmal?
Was ist, wenn Du die BT-Maus ohne GPS-Gate anbindest ?

@Birdman
welche Version läuft bei Dir?
welche Hardware ?

@Checksum
das sind die 3 Zeichen am Ende jedes Strings, also z. B. "*56"
Gruß
Jockel (QV-Admin)

Angefragte Daten für Supportfälle bitte schicken an info/at/quovadis-gps.com unter Bezugnahme (link) auf diesen thread, Danke!

Beiträge: 285

Registrierungsdatum: 16. Juni 2004

Wohnort: Unterhaching

8

Mittwoch, 19. Januar 2005, 16:54

Re: Pathaway & GPSGate - Checksum Fehler

Zitat von »"jockel"«


@Birdman
welche Version läuft bei Dir?
welche Hardware ?


Hallo Jockel,

Hardware: Yakumo delta 300 GPS
PathAway: TTQV EN 3.10.40
GpsGate: v1.10 beta10 (Vollversion)

Gruß,
Birdman

Beiträge: 285

Registrierungsdatum: 16. Juni 2004

Wohnort: Unterhaching

9

Mittwoch, 19. Januar 2005, 17:16

Hallo,

nachfolgend noch ein Ausschnitt eines NMEA-Logfiles, gerade eben mit GpsGate aufgezeichnet:

$GPVTG,,T,,M,,N,,K,N*2C
$GPGGA,155549.808,,,,,0,00,50.0,,M,,,,0000*27
$GPGSA,A,1,,,,,,,,,,,,,50.0,50.0,50.0*05
$GPGSV,3,1,09,19,81,241,,03,55,157,,22,48,061,,15,31,077,*79
$GPGSV,3,2,09,11,31,272,,14,26,116,,18,18,047,,28,10,328,*72
$GPGSV,3,3,09,01,05,153,*43
$GPRMC,155549.808,V,,,,,,,190105,,,N*48
$GPVTG,,T,,M,,N,,K,N*2C
$GPGGA,155550.808,,,,,0,00,50.0,,M,,,,0000*2F
$GPGSA,A,1,,,,,,,,,,,,,50.0,50.0,50.0*05
$GPGSV,3,1,09,19,81,241,,03,55,157,,22,48,061,,15,31,077,*79
$GPGSV,3,2,09,11,31,272,,14,26,116,,18,18,047,,28,10,328,*72
$GPGSV,3,3,09,01,05,153,*43

Gruß,
Birdman

  • »schnoeppi« ist der Autor dieses Themas

Beiträge: 83

Registrierungsdatum: 19. Januar 2005

Wohnort: NRW - Niederrhein

10

Mittwoch, 19. Januar 2005, 20:42

Hallo,

ich benutze folgendes:
Hardware: T-Mobile MDA2
Pathaway: 3.10.40
GPS-Gate: V1.10 Beta 13 (Vollversion)

Ich bekomme zwar jetzt die Daten bei Holux-NMEA im Menü Gerät angezeigt, 3D-Fix leuchtet auf, Fix ist aber 0 und View ebenfalls 0.
Laut GPS-Gate ist aber ein Fix auf jeden Fall vorhanden...


@Birdman,
Probiere doch dann mal folgendes bitte aus:
In deiner Konfiguration "schleifst" du das Signal ja vom Empfänger zum Pathaway durch.
Ich simuliere eine LogDatei an COM0.